+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Hater of Bloom SnesOrama Supporter Skywolf Skywolf Skywolf Skywolf Skywolf Skywolf Skywolf Skywolf Skywolf Skywolf Skywolf Skywolf's Avatar
    Join Date
    Aug 2007
    Location
    Phantomile, City 17, Nürburgring... depends on what video game I'm playing
    Posts
    198

    Post How to Prevent a "Missing Files" Error When Running a Rom in Model 2 Emulator

    If you're reading this tutorial, you're probably stuck in the same situation I was once in. You stumble across some videos on YouTube showing off Daytona USA (or *insert other Model 2 based game here*) running on something called "Nebula Model 2 Emulator." In a nostalgic rush, you dash off to the link provided, download the emulator, and then download a few games elsewhere. You put the roms in the correct folder, load up the emulator in anticipation, click on the game you want to load, and...

    "Files Not Found..."

    You sit there baffled. "What could I be missing? I made sure everything was configured properly!" Yet, no matter what you do, the same error pops up every time...

    I was in this situation myself once. However, thanks to plenty of snooping around on various forums via Google search, along with plenty of experimentation, I was able to circumnavigate this problem and enjoy some classic Model 2 arcade games in the comfort of my own home. However, I realize that not many people out there are as stubborn as I was in trying to figure this out. The aim of this tutorial is to help those stuck in a similar situation, and to prevent the possible headaches that could occur. So, without further adieu...

    How to Prevent a "Missing Files" Error When Running a Rom in Model 2 Emulator

    Now, there are three causes of a “Missing Files” error: either you are lacking a certain .zip file, the rom you are trying to run has some sort of .zip compression, or the rom file is actually missing files. The first two are easily fixed, and are covered in this tutorial. The last cause is actually quite rare, and if such is the case, you probably need to find a better source for your roms.

    CAUSE #1:
    If you are trying to run a game using an early version of the Model 2 board, such as Daytona USA or Virtua Cop, a "Missing Files" error is usually caused by the lack of a file called "model2.zip". This can be downloaded here:
    Code:
    http://www.mediafire.com/?ozkonwwejzx
    TO FIX:
    -1: Download "model2.zip" from the link above
    -2: Place the "model2.zip" file in your Model 2 Emulator roms directory
    Spoiler

    -3: Boot up Model 2 Emulator and load your game. It should load up and run perfectly now.
    Spoiler


    If you are trying to run a game that uses a later version of the Model 2 board, this is most likely not the cause of a "Missing Files" error. However, I would recommend downloading "model2.zip" anyway, especially if you are attempting to download a complete set of Model 2 roms.

    ----------

    CAUSE #2:
    If you are trying to run a rom that uses a later version of the Model 2 board, this is the most likely cause of a "Missing Files" error. Most Model 2 rom files on the internet have some sort of .zip compression in them. This does have the advantage of a smaller download, however this compression is also a major problem.
    When the Model 2 Emulator attempts to load a rom, often any sort of .zip compression conflicts with the emulator. This prevents the emulator from being able to properly read the contents of the .zip file, thus displaying a "Missing Files" error.
    Fixing this is slightly more complicated, but is still quite easy. You will need some sort of archival program, and in this tutorial I will be using both WinRAR and 7zip to demonstrate. If you are using a different archival program, you might need to adjust my directions to carry out the process.
    Also, in this example we will be using a rom of "Sky Target", downloaded from "GameTronik.com".

    TO FIX:
    -1: Open the rom with your archival program and extract the contents into a new folder that has the same exact name as the .zip rom file (minus the .zip extension, of course). If done correctly, you can delete the downloaded .zip file.
    Spoiler

    -2: Go into that newly created folder and highlight all of the files inside. Right click on the files and, with WinRAR, click "Add to Archive". With 7zip, right click, mouse over to "7zip", and click "Add to Archive".
    Spoiler

    -3: Select ".zip" as the archive type and make sure the compression is set so that there is no compression whatsoever. In both WinRAR and 7zip, this setting is called "Store". Also, make sure the .zip file has the same name as the folder all of the files are contained in, and that this name is the correct name for that particular game.
    Spoiler

    -4: After making sure the settings are correct, click "ok" and wait a few moments for your new .zip file to be created.
    Spoiler

    NOTE: You may notice that the newly created .zip file is much larger than the file you originally downloaded (in Sky Target's case, the original file was around 22mb, with the newly created file being about 56mb). If this is not the case, you did not set the compression settings correctly and you will have to repeat steps 2-4.
    Spoiler

    -5: If the new .zip file has been created properly, move the .zip rom into your Model 2 Emulator roms directory. You can now delete the folder containing the extracted rom files, as well.
    Spoiler

    -6: Boot up Model 2 Emulator and load your game. It should load up and run perfectly now.
    Spoiler


    ----------

    Hopefully these two methods will help you prevent a "Missing Files" error. If not, then you may actually be missing files and need to find a different source for your roms.

    That concludes this tutorial. I hope this has prevented some headaches and that this has helped those who wish to enjoy some classic Model 2 arcade games from days gone by.

    Thanks for reading, and I hope you have plenty of fun with this Emulator!


    Uploaded Games, OSTs, and Guides List

    damnant quod non intelligunt
    -They condemn what they do not understand

  2. #2
    Junior Member vice86 is on a distinguished road vice86's Avatar
    Join Date
    Aug 2006
    Location
    Poconos, PA
    Posts
    24
    Thanks man!!! I was exactly in the situation you described with seeing Daytona USA on the m2 emu...lol. You're post solved the problem!! Thank you for posting this up and luckily found it when googling for a solution.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Free counter and web stats